Symptom
When performing a deduplication backup on AIP2016R2, you might encounter Error 9999.
12/20/2017 20:19:25.183 exception(0xc0000094) caught, starting block xxxxxxx, nbr of blocks:32, status: 50 Level=ERROR [0]
12/20/2017 20:19:25.183 ##### Pipe line encounter ERROR: 9999, last error code:0, xxxxxxx Level=ERROR [0]
:
:
12/20/2017 20:19:32.289 {IDS_STRING3018}Exit Code: -701
Cause
exception (0xc0000094) caught:
During the deduplication image creation process, CRC is utilized for consistency checks. If the checksum of block xxxxxxx shows 0 during this check, it triggers an exception error, specifically STATUS_INTEGER_DIVIDE_BY_ZERO.
Exception errors can result from various factors like hardware issues or software bugs. However, in this case, the high likelihood is that the error stems from a bug.
Workarounds
Please try one of the following methods:
1) Add a parameter by opening aip.ini with Notepad and including it in the following section.
[aipcopy]
dd_save_blockcrc = 0
* Using this parameter causes deduplication processing to write to the temp file and then compare it. As a result, the disk I/O load increases, and backup time tends to be longer.
2) Switch to standard compression by editing the schedule settings. After making this change, incremental backup continuation won't be possible; therefore, perform a full backup instead.
3) Upgrade to AIP2018
This bug has been resolved in AIP2018.
Target Products
– ActiveImage Protector 2016 R2 Windows
– ActiveImage Protector 4
(13451126527897)
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