Details
If the backup task encounters Exit Code -311, errors are logged in the Windows Event Log and Application Log.
Log Name: System Source: Volsnap Date: 2021/02/09 13:41:16 Event ID: 67 Level: Error Description: Installation of the created shadow copy of Volume "C:" failed.
Log Name: Application Source: VSS Date: 2021/02/09 13:41:16 Event ID: 12289 Level: Error Description: Volume Shadow Copy Service Error: Unexpected Error DeviceIoControl(?Volume{5cdd3a0c-5699-4476-8169-4d94dcd7e422} -000000000000028C,0x0053c008,0000027B47C09F10,0,0000027B47C0AF40,4096,[0]) hr = 0x80070079, The semaphore timeout period has expired. Operation: Processing EndPrepareSnapshots.
Causes
Navigate to [Device Manager], enable [Show hidden devices] in [View], open storage volume shadow copy, and you'll see [Generic Volume Shadow Copy]. If this device isn't deleted or created correctly, it causes the mentioned VSS error, leading to backup task failure.
This device is associated with snapshots and is created when a snapshot is taken.
Workaround
Use the Microsoft DevNodeClean tool to completely delete the unnecessary [Generic Volume Shadow Copy] device. Download the tool from the following site:
https://www.microsoft.com/en-us/download/details.aspx?id=42286
Select [Run as Administrator] and run DevNodeClean.exe.
Deleting the [Generic Volume Shadow Copy] device usually allows the backup task to run.
Target Products
– ActiveImage Protector 2018 Windows
(13451131439001)
Comments
0 comments
Article is closed for comments.