Summary
Identified the issue that after running a scheduled incremental backup task, Scheduler.log was bloated.
Causes
After running a scheduled incremental backup task, the profile of the incremental backup is incorrectly read and the looping internal processing is identified.
The following message is recorded every second in Schduler.log in AIP install path, so that Schduler.log is bloated.
12/09/2022 00:39:36.079 0 File(C:\Program Files (x86)\NetJapan\ActiveImage Protector\Schedules\Backup_20221208_0147.xml), write next run: 0
12/09/2022 00:39:37.080 0 File(C:\Program Files (x86)\NetJapan\ActiveImage Protector\Schedules\Backup_20221208_0147.xml), write next run: 0
Workaround
Windows Edition
1) Launch AIP console, go to [Dashboard] - [Schedule] and delete the appropriate schedule.
2) Go to Windows Service and stop ActiveImage Protector Service.
3) Manually delete Scheduler.log under AIP install path.
4) Go to Windows Service and start ActiveImage Protector Service.
Linux Edition
1) Launch AIP console, go to [Dashboard] - [Schedule] and delete the appropriate schedule. If GUI is not available and connected to a remote host, please launch Linux terminal and delete the following file.
Ex.) When the schedule is named "test". # rm /opt/NetJapan/profiles/test.xml # rm /opt/NetJapan/profiles/testINC.xml # rm /opt/NetJapan/schedules/test.xml
2) Stop aipservice and delete Scheduler.log.
# killall aipservice
# killall aipscheduler
# rm /opt/NetJapan/Scheduler.log
3) Start aipservice.
# /opt/NetJapan/aipservice
This issue was fixed with the following or later versions, please update to the following or later version.
Windows Edition update2 Version 5.1.9.5691 or later
Linux Edition update5 Version 5.1.9.5983 or later
Target Product
- ActiveImage Protector 2018 Windows Edition
- ActiveImage Protector 2018 Linux Edition
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