Summary
Occasionally, Hyper-V VMMS may face an issue preventing the automatic removal and merging of backup checkpoints for specific virtual machines. This can lead to the persistence of the backup Hyper-V checkpoint, visible in Hyper-V Manager, causing subsequent backup attempts to fail. To address this problem, follow the steps below.
Cause
When VSS runs on the drive containing the Hyper-V host's VM, the VM status becomes [Backing up...]. As a checkpoint can't be created in this state, the HyperBack task fails with the following error.
07/07/2020 01:13:11.027 NJHyperVGetRCTOneDiskPathAndTrackingID return error 0X7014 Level=ERROR [183]
07/07/2020 01:13:11.028 {IDS_STRING3018}Exit Code: 28678
07/07/2020 01:13:11.028 [28678] Unknown AIP error
Workaround
1. Check and removal of relevant checkpoints
- Launch Windows PowerShell with administrative privileges on the impacted Hyper-V host.
- You can initially inspect all linked Hyper-V backup checkpoints for each virtual machine using the following command. Execute the command while specifying the Hyper-V host and VM:
Get-VMSnapshot -ComputerName "HOST" -VMName "VM"
Note: The fully qualified domain name (FQDN) of your Hyper-V host may need to be used. - To remove the Hyper-V backup checkpoints, you need to run the following command:
Get-VMSnapshot -ComputerName "HOST" -VMName "VM" | Remove-VMSnapshot
- This may take a while. Ensure there is a minimum of 5% free space on the hard disk.
2. Clear Hyper-V cache
If a Hyper-V backup checkpoint persists in Hyper-V Manager even after using the PowerShell solution, and the virtual machine is already accessing the standard virtual hard disks (* .VHD or * .VHDX), the Hyper-V snapshot cache still remains.
- If your virtual machine no longer has any * .AVHD or *.AVHDX files, the display in Hyper-V Manager is merely the cache of the Hyper-V snapshot. To clear the cache, follow these steps:
- Shut down the affected virtual machine.
- Stop the Hyper-V VMMS "Hyper-V Virtual Machine Management" service.
- Start the Hyper-V VMMS service "Hyper-V Virtual Machine Management".
- Start the virtual machine.
3. Resolving permission issues when deleting Hyper-V backup checkpoints
You encounter error event 19100 in the Windows Event Viewer on the Hyper-V host:
Hyper-V-VMMS 19100 'VM1' Background Disk Merge Could Not Complete: General Access Denied Error (0x80070005)
The problem is due to incorrect permissions. To fix this, provide additional permissions for the folder, virtual disk files, checkpoint files, and the VMMS process. Start by identifying the GUIDs of the affected virtual guests.
- Start PowerShell as administrator and enter the following command:
get-vm | fl name, id
Example output:
Name : VM1
Id : d3599536-222a-4d6e-bb10-a6019c3f2b9b
Name : VM2
Id : a0af7903-94b4-4a2c-b3b3-16050d5f80f
For each GUID of a virtual machine, set full control for the VMMS process with the following command:
icacls "YOUR PATH" /grant "NT VIRTUAL MACHINE\YOUR ID:(OI)F"
Example:
icacls "C:\ClusterStorage\Volume1\VM1" /grant "NT VIRTUAL MACHINE\d3599536-222a-4d6e-bb10-a6019c3f2b9b:(OI)F"
icacls "C:\ClusterStorage\Volume1\VM2" /grant "NT VIRTUAL MACHINE\a0af7903-94b4-4a2c-b3b3-16050d5f80f2:(OI)F"
- Repeat the process if required for other virtual guests.
Target Product
– ActiveImage Protector 2018 Update or later
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