Summary
There is a problem with the Microsoft VSS Framework. You will find below a list of possible causes for your problem with possible solutions.
Cause
While creating the backup with VSS the following error might appear:
[-311] Could not start VSS Level=ERROR [0]
Workaround
1. Adjust backup times
High I/O loads are often the cause of VSS timeouts. It is recommended to never run the backup tasks on the hour, as other maintenance tasks often start in the background during these periods. For example, set the start times 10 to 15 minutes off the hour to avoid such problems.
2. Check free space
Make sure that there is at least 5%, better 10% free space on the volumes to be backed up.
3. Delete old unused shadow copies
- Start the Windows command prompt as administrator.
- Enter
vssadmin delete shadows /all
. Confirm with "j" to delete all shadow copies. - Enter
set DEVMGR_SHOW_NONPRESENT_DEVICES=1
. - Enter
devmgmt.msc
to open the device manager. - Then select "View" -> "Show hidden devices in the Device Manager".
- Scroll down to the "Memory Volume Shadow Copy" section.
- Under "Storage Volume Shadow Copy" you will see "Standard Volume Shadow Copy" listed. These elements are displayed grayed out.
- To remove the elements, right-click on the element and select Uninstall. Alternatively, select an item and press the Del key followed by the Enter key to delete it.
- Repeat these steps until all grayed out elements are removed.
- Delete all grayed-out items in the "Storage volume" section and as well.
4. Increase shadow copy memory
In this example, we increase the shadow copy space on the C: drive by 10 GB.
Variant 1 via command prompt
- Start the Windows command prompt as administrator.
- Enter
vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=10GB
. - To increase the size, enter
vssadmin Resize shadowstorage /For=C: /On=C: /MaxSize=UNBOUNDED
. - We recommend setting the shadow copy storage between 10% to 15%. If you have larger volumes of data and do not use Windows' own shadow copy feature, set the shadow copy storage to unlimited.
Variant 2 via Windows GUI
- Start Windows File Explorer and select the C: drive by right-clicking on it.
- Select "Configure shadow copies" (for desktop operating systems via -> System -> Computer protection).
- For older server operating systems, select the C: drive by right-clicking -> "Properties" and then select "Shadow Copies" as a tab.
- Select the drive and set the desired size via "Settings".
5. Repair VSS Framework
If the problem persists despite the above, the VSS framework can be re-registered. The instructions are for 32bit and 64bit systems. Error messages may appear which have no influence on the result.
1. Copy these lines into an empty Windows Notepad file, which you save as a batch file with the file extension *.bat:
cd /d %windir%\system32
Net stop vss
Net stop swprv
regsvr32 ole32.dll
regsvr32 vss_ps.dll
Vssvc /Register
regsvr32 /i swprv.dll
regsvr32 /i eventcls.dll
regsvr32 es.dll
regsvr32 stdprov.dll
regsvr32 vssui.dll
regsvr32 msxml.dll
regsvr32 msxml3.dll
regsvr32 msxml4.dll
regsvr32 Vssapi.dll
regsvr32 Vssui.dll
net start vss
net start swprv
Additionally for 64 bit operating systems, add the following lines to the batch file:
Net stop vss
Net stop swprv
regsvr32.exe /i %windir%\system32\eventcls.dll
regsvr32.exe /i %windir%\system32\swprv.dll
regsvr32.exe %windir%\system32\vssui.dll
regsvr32.exe %windir%\SysWOW64\vss_ps.dll
regsvr32.exe %windir%\SysWOW64\msxml.dll
regsvr32.exe %windir%\SysWOW64\msxml2.dll
regsvr32.exe %windir%\SysWOW64\msxml3.dll
regsvr32.exe %windir%\SysWOW64\msxml4.dll
regsvr32.exe %windir%\SysWOW64\ole32.dll
regsvr32.exe %windir%\SysWOW64\oleaut32.dll
regsvr32.exe %windir%\SysWOW64\es.dll
regsvr32.exe %windir%\SysWOW64\comsvcs.dll
vssvc /register
net start swprv
net start vss
net stop winmgmt
regsvr32 wmiutils.dll
net start winmgmt
2. Run the batch file as administrator and restart the system.
Target Product
– ActiveImage Protector 2018Update or later
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