概要
指定時間で作成したスケジュールの動作後、Scheduler.logが肥大化する現象が確認されています。
原因
指定時間で作成したスケジュールの動作後、増分のプロファイルを不正に読み取ってしまい、内部処理のループが発生することが判明しています。
AIPインストールパスのSchduler.logには下記のメッセージが毎秒記録されていき、ログが肥大化してしまいます。
12/09/2022 00:39:36.079 0 File(C:\Program Files (x86)\NetJapan\ActiveImage Protector\Schedules\Backup_20221208_0147.xml), write next run: 0
12/09/2022 00:39:37.080 0 File(C:\Program Files (x86)\NetJapan\ActiveImage Protector\Schedules\Backup_20221208_0147.xml), write next run: 0
回避策
Windows Edition
1) AIPコンソールのダッシュボードのスケジュールを開いて、該当するスケジュールを削除します。
2) Windows サービスより、 ActiveImage Protector Service サービスを停止します。
3) AIPインストールパス直下の Scheduler.logを手動で削除します。
4) Windows サービスより、 ActiveImage Protector Service サービスを開始します。
Linux Edition
1) AIPコンソールのダッシュボードのスケジュールを開いて、該当するスケジュールを削除します。 GUIの無い環境でリモート接続している場合は、下記ファイルをLinuxターミナルを使用して削除します。
例) test という名前のスケジュールの場合 # rm /opt/NetJapan/profiles/test.xml # rm /opt/NetJapan/profiles/testINC.xml # rm /opt/NetJapan/schedules/test.xml
2) aipservice サービスを停止し、Scheduler.logを削除します。
# killall aipservice
# killall aipscheduler
# rm /opt/NetJapan/Scheduler.log
3) aipservice サービスを開始します。
# /opt/NetJapan/aipservice
この現象は、下記バージョン以降で修正されましたので、下記以降のバージョンへアップデートを実施ください。
Windows Edition update2 バージョン 5.1.9.5691 以降
Linux Edition update5 バージョン 5.1.9.5983 以降
対象製品
- ActiveImage Protector 2018 Windows Edition
- ActiveImage Protector 2018 Linux Edition
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