概要
Hyper-Vホストへの接続がアクセス拒否で失敗する現象が確認されています。
主には下記のような操作で、リモート先のHyper-Vホストへ接続を試みた場合に、ユーザー名とパスワードが正しいにもかかわらず、下記の症状が発生し認証が失敗する場合があります。
1) AIPコンソール左パネルの [スタンバイ] > [HyperStandby] で、イメージファイルのパスを登録後、タスク作成でHyper-Vへ認証すると下記赤字が表示される。
ユーザー名またはパスワードが間違っています。再度入力してください。
2) AIPコンソール左パネルの [スタンバイ] > [vStandby] で、Hyper-Vの認証を行うと、接続中のロード中のアイコンが表示されるが、数秒待つと接続できずに止まる。結果として次の操作に進めない。
3)AIPコンソールの [環境設定] > [ハイパーバイザー] > [ハイパーバイザーを追加...] から、リモート先の Hyper-V を登録しようとすると、赤字で下記のメッセージが表示される。
Connection error! Please check the IP address or certification.
4) AIPコンソールの [仮想化] > [イメージから変換] または [ディスクから変換] から、Hyper-Vを指定し接続を行うと、下記メッセージが表示され接続に失敗する。
指定ホストへの接続中にエラーが発生しました。 [OK]
接続エラーは、下記ログに記録されます。今回のケースでは、アクセス拒否 (0x80070005) の発生を記録します。
AIPインストールパス\logs\hyper-v\AipService_日付の数字.log
原因
接続元からHyper-VへのWMI接続が正常に行えないためです。
AIP側での解決策はありません。
弊社の調査では、認証元の環境と認証先のHyper-Vの環境の両方に対して Windows Update で最新まで適用した場合、WMI接続の成功を確認しています。
WMI接続の確認方法:
1) Windowsスタートメニューの右クリック > [ファイル名を指定して実行] -- wbemtest と入力し「Windows Management Instrumentation テスト」を起動します。
[接続] をクリックします。
2) 接続画面で、名前空間に \\接続先Hyper-VのIP\\root\cimv2 と入力し [接続] をクリックします。下記のようにエラー画面が表示された場合、AIPでもHyper-Vに対し認証ができません。
成功すると、下記のように 名前空間:\\IP\\root\cim2 のパスに対して接続成功の状況になります。
Windows Updateが行えない場合、下記の記事を参考頂き、解決しない場合はベンダーやマイクロソフトにお問い合わせください。
シナリオ ガイド: WMI 接続とアクセスに関する問題のトラブルシューティング
https://learn.microsoft.com/ja-jp/troubleshoot/windows-server/system-management-components/scenario-guide-troubleshoot-wmi-connectivity-access-issues
対象製品
- ActiveImage Protector 2022
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