概要
FortiClientがセットアップされている環境でActiveImage Protector のアップグレード処理が停止し続ける現象が確認されています。
アップグレード中の進捗画面では、下記メッセージの表示で停止し続けています。
Action start XX:XX:XX: CA_CheckProcesses.
原因
CA_CheckProcesses の処理では、ActiveImage Protectorをアンインストールまたはアップグレードする際、以下のプロセス名をチェックし、起動している場合は停止を行います。しかし、他の製品が同じ名前のプロセス名を使用しているような場合、CA_CheckProcessesの処理で停止し続けてしまいます。
プロセス名 (Windowsのタスクマネージャー > [詳細]タブで確認可能です)
AIProtector.exe
AIPTask.exe
USBDetector.exe
Scheduler.exe
AipNotify.exe
MediaMaker.exe
AutoUpdate.exe
FortiClient が Scheduler.exe という同名のプログラムを使用していたため、 CA_CheckProcesses の処理が停止し続けていました。
回避策
Windows のトレイアイコンに存在する FortiClient のアイコンを 右クリック > FortiClientシャットダウン をクリックしてください。操作後、ActiveImage Protector のアンインストールまたはアップグレード処理は継続し、正常に完了します。
当該記事の対策として、ActiveImage Protector バージョン 7.5.0.9448 以降、プログラム名の重複を避けるため Scheduler.exe を AIPScheduler.exe に変更しました。また、当該記事の条件でもアップグレード処理が正常に行える処理も含まれています。
尚、FortiClientが導入されていない環境でも、当該記事の処理で長時間停止する場合があります。その場合、原因に記載の各プロセス名を1つずつ 、Windowsタスクマネージャの [詳細] タブ より 右クリック>タスクの終了 -- プロセスの終了 で強制終了することで、アップグレード処理が進む場合があります。この方法でアップグレードが成功した場合、正常にアップグレードは完了していますので、引き続き製品をご利用ください。
対象製品
- ActiveImage Protector 2022 7.0.3.8919 までのすべて
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