Summary
The ActiveImage Protector upgrade process halts when FortiClient is installed. During the upgrade, the progress window displays a message indicating the process has stopped.
Action start XX:XX:XX: CA_CheckProcesses.
Causes
When uninstalling or upgrading ActiveImage Protector, the CA_CheckProcesses checks the following processes names and stops them if they are running. However, when the same process name is used by other product, CA_CheckProcesses will continue to halt at CA_CheckProcesses process.
Process Name (Go to Windows Task Manager > [Details] and you can check the process name.)
AIProtector.exe
AIPTask.exe
USBDetector.exe
Scheduler.exe
AipNotify.exe
MediaMaker.exe
AutoUpdate.exe
Since FortiClient was using a program of the same name, i.e., Scheduler.exe, CA_CheckProcesses continued to halt.
Workaround
Right-click the FortiClient icon in the Windows Tray and select "Shut-down FortiClient." After this, the ActiveImage Protector uninstall or upgrade will resume and finish successfully.
As a countermeasure to this issue as from ActiveImage Protector Version 7.5.0.9448 or later, in order to avoid duplication of the program names, "Scheduler.exe" is changed to "AIPScheduler.exe". Even under the above conditions, the process for a successful upgrade is included.
Even when FortiClient is not installed, the ActiveImage Protector upgrade process may halt for a long time. If you encounter the problem, right-click every process as above mentioned in "Causes", in [Details] tab in Windows Task Manager > End Task -- End Process to force shutdown. Then upgrade process may continue. When upgrading successfully completes by using the above procedures, upgrading has normally completed and you can continue to use the product.
Target Product
- ActiveImage Protector 2022 7.0.3.8919 or earlier
(37016165905817)
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