Summary
The ActiveImage Protector upgrade process halts when FortiClient is installed. During the upgrade, the progress window displays a message indicating the process has stopped.
Action start XX:XX:XX: CA_CheckProcesses.
Causes
When uninstalling or upgrading ActiveImage Protector, the CA_CheckProcesses checks the following processes names and stops them if they are running. However, when the same process name is used by other product, CA_CheckProcesses will continue to halt at CA_CheckProcesses process.
Process Name (Go to Windows Task Manager > [Details] and you can check the process name.)
AIProtector.exe
AIPTask.exe
USBDetector.exe
Scheduler.exe
AipNotify.exe
MediaMaker.exe
AutoUpdate.exe
Since FortiClient was using a program of the same name, i.e., Scheduler.exe, CA_CheckProcesses continued to halt.
Workaround
Right-click the FortiClient icon in the Windows Tray and select "Shut-down FortiClient." After this, the ActiveImage Protector uninstall or upgrade will resume and finish successfully.
As a countermeasure to this issue, in order to avoid duplication of the program names, "Scheduler.exe" is changed to "AIPScheduler.exe". Even under the above conditions, the process for a successful upgrade is included.
Target Product
- ActiveImage Protector 2022 7.0.3.8919 or earlier
(37016165905817)
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